next round of build system cleanup - convert package/ to new structure
[openwrt-10.03/.git] / include / subdir.mk
index 046a6adf6f370c32310d8b5d933a8eb23b833c42..a27333d9e62394b9cdcae1627173e080c81381a0 100644 (file)
@@ -1,29 +1,16 @@
-# debug flags:
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
-# d: show subdirectory tree
-# t: show added targets
-# l: show legacy targets
-
-ifeq ($(DEBUG),all)
-  build_debug:=dlt
-else
-  build_debug:=$(DEBUG)
-endif
-
-define debug
-$$(findstring $(2),$$(if $$(DEBUG_DIR),$$(if $$(filter $$(DEBUG_DIR)%,$(1)),$(build_debug)),$(build_debug)))
-endef
 
-define warn
-$$(if $(call debug,$(1),$(2)),$$(warning $(3)))
-endef
+SUBTARGETS:=clean download prepare compile install update refresh prereq
 
-define warn_eval
-$(call warn,$(1),$(2),$(3)     $(4))
-$(4)
-endef
+define subtarget
+  $(call warn_eval,$(1),t,T,$(1)/$(2): $($(1)/) $(foreach bd,$(if $($(1)/builddirs-$(2)),$(filter-out .,$($(1)/builddirs-$(2))),$($(1)/builddirs)),$(1)/$(bd)/$(2)))
 
-SUBTARGETS:=clean download prepare compile install update refresh prereq
+endef
 
 # Parameters: <subdir>
 define subdir
@@ -32,30 +19,28 @@ define subdir
     $(call warn,$(1),d,BD $(1)/$(bd))
     $(foreach target,$(SUBTARGETS),
       $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd)))
-               @$$(MAKE) -j1 -C $(1)/$(bd) $(target)
+               @+$$(MAKE) -j1 -C $(1)/$(bd) $(target)
 
       # legacy targets
       $(call warn_eval,$(1)/$(bd),l,T,$(1)/$(bd)-$(target): $(1)/$(bd)/$(target))
        )
   )
-  $(foreach target,$(SUBTARGETS),
-    $(call warn_eval,$(1),t,T,$(1)/$(target): $($(1)/) $(foreach bd,$($(1)/builddirs),$(1)/$(bd)/$(target)))
-  )
+  $(foreach target,$(SUBTARGETS),$(call subtarget,$(1),$(target)))
 endef
 
-# Parameters: <subdir> <name>
+# Parameters: <subdir> <name> <target>
 define stampfile
-  $(1)/stamp:=$(STAGING_DIR)/stampfiles/.$(2)_installed
-  $(call rdep,$(1),$$($(1)/stamp))
-
-  $$($(1)/stamp):
-       @$(MAKE) $(1)/install
-       @mkdir -p $$$$(dirname $$($(1)/stamp))
-       @touch $$($(1)/stamp)
-  .PRECIOUS: $$($(1)/stamp) # work around a make bug
-
-  $(1)//clean:=$(1)/stamp/clean
-  $(1)/stamp/clean: FORCE
-       @rm -f $$($(1)/stamp)
+  $(1)/stamp-$(3):=$(STAGING_DIR)/stampfiles/.$(2)_$(3)
+  $(call rdep,$(1),$$($(1)/stamp-$(3)),)
+
+  $$($(1)/stamp-$(3)):
+       @+$(MAKE) $(1)/$(3)
+       @mkdir -p $$$$(dirname $$($(1)/stamp-$(3)))
+       @touch $$($(1)/stamp-$(3))
+  .PRECIOUS: $$($(1)/stamp-$(3)) # work around a make bug
+
+  $(1)//clean:=$(1)/stamp-$(3)/clean
+  $(1)/stamp-$(3)/clean: FORCE
+       @rm -f $$($(1)/stamp-$(3))
 
 endef