build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail...
[openwrt-10.03/.git] / include / subdir.mk
index fe46ed0de04c26d2d1f197139cde3ba3bb000dc9..28b01b6370c637cd74c78632ff34cda17fa8215d 100644 (file)
@@ -1,29 +1,21 @@
-# debug flags:
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
-# d: show subdirectory tree
-# t: show added targets
-# l: show legacy targets
-
-ifeq ($(DEBUG),all)
-  build_debug:=dt
-else
-  build_debug:=$(DEBUG)
-endif
-
-define debug
-$$(findstring $(2),$$(if $$(DEBUG_DIR),$$(if $$(filter $$(DEBUG_DIR)%,$(1)),$(build_debug)),$(build_debug)))
-endef
 
-define warn
-$$(if $(call debug,$(1),$(2)),$$(warning $(3)))
-endef
+SUBTARGETS:=clean download prepare compile install update refresh prereq
 
-define warn_eval
-$(call warn,$(1),$(2),$(3)     $(4))
-$(4)
-endef
+subtarget-default = $(filter-out ., \
+       $(if $($(1)/builddirs-$(2)),$($(1)/builddirs-$(2)), \
+       $(if $($(1)/builddirs-default),$($(1)/builddirs-default), \
+       $($(1)/builddirs))))
 
-SUBTARGETS:=clean download prepare compile install update refresh prereq
+define subtarget
+  $(call warn_eval,$(1),t,T,$(1)/$(2): $($(1)/) $(foreach bd,$(call subtarget-default,$(1),$(2)),$(1)/$(bd)/$(2)))
+
+endef
 
 # Parameters: <subdir>
 define subdir
@@ -31,31 +23,36 @@ define subdir
   $(foreach bd,$($(1)/builddirs),
     $(call warn,$(1),d,BD $(1)/$(bd))
     $(foreach target,$(SUBTARGETS),
-      $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd)))
-               @$$(MAKE) -j1 -C $(1)/$(bd) $(target)
+      $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd))))
+               +$$(MAKE) -j1 -C $(1)/$(bd) $(target)
+        $$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(target))
 
       # legacy targets
       $(call warn_eval,$(1)/$(bd),l,T,$(1)/$(bd)-$(target): $(1)/$(bd)/$(target))
        )
   )
-  $(foreach target,$(SUBTARGETS),
-    $(call warn_eval,$(1),t,T,$(1)/$(target): $($(1)/) $(foreach bd,$($(1)/builddirs),$(1)/$(bd)/$(target)))
-  )
+  $(foreach target,$(SUBTARGETS),$(call subtarget,$(1),$(target)))
 endef
 
-# Parameters: <subdir> <name>
+# Parameters: <subdir> <name> <target>
 define stampfile
-  $(1)/stamp:=$(STAGING_DIR)/stampfiles/.$(2)_installed
-  $(call rdep,$(1),$$($(1)/stamp))
-
-  $$($(1)/stamp):
-       @$(MAKE) $(1)/install
-       @mkdir -p $$$$(dirname $$($(1)/stamp))
-       @touch $$($(1)/stamp)
-  .PRECIOUS: $$($(1)/stamp) # work around a make bug
-
-  $(1)//clean:=$(1)/stamp/clean
-  $(1)/stamp/clean: FORCE
-       @rm -f $$($(1)/stamp)
+  $(1)/stamp-$(3):=$(STAGING_DIR)/stampfiles/.$(2)_$(3)
+  $(if $(__rdep_$(1)),,
+    $(call rdep,$(1),$$($(1)/stamp-$(3)),)
+    __rdep_$(1):=1
+  )
+
+  $$($(1)/stamp-$(3)):
+       @+$(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
+       @mkdir -p $$$$(dirname $$($(1)/stamp-$(3)))
+       @touch $$($(1)/stamp-$(3))
+
+  $$(if $(call debug,$(1),v),,.SILENT: $$($(1)/stamp-$(3)))
+
+  .PRECIOUS: $$($(1)/stamp-$(3)) # work around a make bug
+
+  $(1)//clean:=$(1)/stamp-$(3)/clean
+  $(1)/stamp-$(3)/clean: FORCE
+       @rm -f $$($(1)/stamp-$(3))
 
 endef