build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail...
[openwrt-10.03/.git] / include / subdir.mk
index e985c30ff0f3dd632a835fec227d820c0b67c62d..28b01b6370c637cd74c78632ff34cda17fa8215d 100644 (file)
@@ -37,7 +37,7 @@ endef
 # Parameters: <subdir> <name> <target>
 define stampfile
   $(1)/stamp-$(3):=$(STAGING_DIR)/stampfiles/.$(2)_$(3)
-  $(if __rdep_$(1),,
+  $(if $(__rdep_$(1)),,
     $(call rdep,$(1),$$($(1)/stamp-$(3)),)
     __rdep_$(1):=1
   )