build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail...
[openwrt-10.03/.git] / include / subdir.mk
index da37573c7820d904174833aae718638e43c461f4..28b01b6370c637cd74c78632ff34cda17fa8215d 100644 (file)
@@ -23,8 +23,9 @@ define subdir
   $(foreach bd,$($(1)/builddirs),
     $(call warn,$(1),d,BD $(1)/$(bd))
     $(foreach target,$(SUBTARGETS),
-      $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd)))
-               @+$$(MAKE) -j1 -C $(1)/$(bd) $(target)
+      $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(if $(QUILT),,$($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd))))
+               +$$(MAKE) -j1 -C $(1)/$(bd) $(target)
+        $$(if $(call debug,$(1)/$(bd),v),,.SILENT: $(1)/$(bd)/$(target))
 
       # legacy targets
       $(call warn_eval,$(1)/$(bd),l,T,$(1)/$(bd)-$(target): $(1)/$(bd)/$(target))
@@ -36,12 +37,18 @@ endef
 # Parameters: <subdir> <name> <target>
 define stampfile
   $(1)/stamp-$(3):=$(STAGING_DIR)/stampfiles/.$(2)_$(3)
-  $(call rdep,$(1),$$($(1)/stamp-$(3)),)
+  $(if $(__rdep_$(1)),,
+    $(call rdep,$(1),$$($(1)/stamp-$(3)),)
+    __rdep_$(1):=1
+  )
 
   $$($(1)/stamp-$(3)):
-       @+$(MAKE) $(1)/$(3)
+       @+$(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
        @mkdir -p $$$$(dirname $$($(1)/stamp-$(3)))
        @touch $$($(1)/stamp-$(3))
+
+  $$(if $(call debug,$(1),v),,.SILENT: $$($(1)/stamp-$(3)))
+
   .PRECIOUS: $$($(1)/stamp-$(3)) # work around a make bug
 
   $(1)//clean:=$(1)/stamp-$(3)/clean