next round of build system cleanup - convert package/ to new structure
[openwrt-10.03/.git] / include / quilt.mk
index fb5528e884c6762a8fdc71a01232788f2cda77e7..dc5a9d2b698e002b0a26020bd669f300c2d3a4b2 100644 (file)
@@ -10,6 +10,10 @@ ifeq ($(KERNEL_BUILD),1)
 endif
 PATCH_DIR?=./patches
 
 endif
 PATCH_DIR?=./patches
 
+ifeq ($(MAKECMDGOALS),refresh)
+  override QUILT=1
+endif
+
 define Quilt/Patch
        @for patch in $$$$( (cd $(1) && ls) 2>/dev/null ); do ( \
                cp "$(1)/$$$$patch" $(PKG_BUILD_DIR); \
 define Quilt/Patch
        @for patch in $$$$( (cd $(1) && ls) 2>/dev/null ); do ( \
                cp "$(1)/$$$$patch" $(PKG_BUILD_DIR); \
@@ -61,7 +65,7 @@ $(STAMP_PATCHED): $(STAMP_PREPARED)
                cd $(PKG_BUILD_DIR)/patches; \
                find * -type f \! -name series | sort > series; \
        )
                cd $(PKG_BUILD_DIR)/patches; \
                find * -type f \! -name series | sort > series; \
        )
-       -[ -s "$(PKG_BUILD_DIR)/patches/series" ] && (cd $(PKG_BUILD_DIR); quilt push -a)
+       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt push -a); fi
        touch $@
 
 define Quilt/RefreshDir
        touch $@
 
 define Quilt/RefreshDir