next round of build system cleanup - convert package/ to new structure
[openwrt-10.03/.git] / include / quilt.mk
index 86008e2f14e7349e585b4fdb0099c65d2a98ec06..dc5a9d2b698e002b0a26020bd669f300c2d3a4b2 100644 (file)
@@ -10,6 +10,10 @@ ifeq ($(KERNEL_BUILD),1)
 endif
 PATCH_DIR?=./patches
 
+ifeq ($(MAKECMDGOALS),refresh)
+  override QUILT=1
+endif
+
 define Quilt/Patch
        @for patch in $$$$( (cd $(1) && ls) 2>/dev/null ); do ( \
                cp "$(1)/$$$$patch" $(PKG_BUILD_DIR); \
@@ -25,7 +29,6 @@ ifneq ($(QUILT),)
   STAMP_PREPARED:=$(strip $(STAMP_PREPARED))_q
   STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
   override CONFIG_AUTOREBUILD=
-  PATCHES:=$(shell )
   define Build/Patch/Default
        rm -rf $(PKG_BUILD_DIR)/patches
        mkdir -p $(PKG_BUILD_DIR)/patches
@@ -62,7 +65,7 @@ $(STAMP_PATCHED): $(STAMP_PREPARED)
                cd $(PKG_BUILD_DIR)/patches; \
                find * -type f \! -name series | sort > series; \
        )
-       [ -f "$(PKG_BUILD_DIR)/patches/series" ] && cd $(PKG_BUILD_DIR); quilt push -a
+       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt push -a); fi
        touch $@
 
 define Quilt/RefreshDir