do not ignore exit codes of quilt anymore (by nbd)
[openwrt-10.03/.git] / include / quilt.mk
index d3233d823895cbcd06a3e742bad047923f507d37..c47a9262d91df5f8b272058a0d8ca46ffc15e15b 100644 (file)
@@ -126,7 +126,7 @@ define Build/Quilt
 
   $(STAMP_CONFIGURED): $(STAMP_CHECKED) FORCE
   $(STAMP_CHECKED): $(STAMP_PATCHED)
-       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt next >/dev/null 2>&1 && quilt push -a || quilt top >/dev/null 2>&1); fi
+       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); if quilt next >/dev/null 2>&1; then quilt push -a; else quilt top; fi >/dev/null 2>&1); fi
        touch $$@
 
   quilt-check: $(STAMP_PREPARED) FORCE