add kernel_oldconfig target
[openwrt-10.03/.git] / include / quilt.mk
index 47195293e881df9b28fe9b0faa5a56956d16cc9e..2e7941eaed3f9e7a20c53107271fde6cce74a8b7 100644 (file)
@@ -8,6 +8,7 @@
 ifeq ($(KERNEL_BUILD),1)
   PKG_BUILD_DIR:=$(LINUX_DIR)
 endif
+PATCH_DIR?=./patches
 
 define Quilt/Patch
        @for patch in $$$$( (cd $(1) && ls) 2>/dev/null ); do ( \
@@ -23,12 +24,11 @@ QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
 ifneq ($(QUILT),)
   STAMP_PREPARED:=$(strip $(STAMP_PREPARED))_q
   STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
-  CONFIG_AUTOREBUILD=
-  PATCHES:=$(shell )
+  override CONFIG_AUTOREBUILD=
   define Build/Patch/Default
        rm -rf $(PKG_BUILD_DIR)/patches
        mkdir -p $(PKG_BUILD_DIR)/patches
-       $(call Quilt/Patch,./patches,)
+       $(call Quilt/Patch,$(PATCH_DIR),)
        @echo
        touch $(PKG_BUILD_DIR)/.quilt_used
   endef
@@ -37,8 +37,8 @@ ifneq ($(QUILT),)
   quilt-check: $(STAMP_PATCHED)
 else
   define Build/Patch/Default
-       @if [ -d ./patches -a "$$$$(ls ./patches | wc -l)" -gt 0 ]; then \
-               $(PATCH) $(PKG_BUILD_DIR) ./patches; \
+       @if [ -d $(PATCH_DIR) -a "$$$$(ls $(PATCH_DIR) | wc -l)" -gt 0 ]; then \
+               $(PATCH) $(PKG_BUILD_DIR) $(PATCH_DIR); \
        fi
   endef
 endif
@@ -75,7 +75,7 @@ define Quilt/RefreshDir
 endef
 
 define Quilt/Refresh/Package
-       $(call Quilt/RefreshDir,./patches)
+       $(call Quilt/RefreshDir,$(PATCH_DIR))
 endef
 
 define Quilt/Refresh/Kernel