add prereq check to prevent people from building openwrt as root
[openwrt-10.03/.git] / include / prereq-build.mk
index a6de9b270aa74d784e70071055cdd1ae10c0d517..e90c3157b050a5e1ebc9097ac6855f5dcf799480 100644 (file)
@@ -8,6 +8,13 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
 
+define Require/non-root
+       [ "$$(shell whoami)" != "root" ]
+endef
+$(eval $(call Require,non-root, \
+       Building OpenWrt as root is not supported! \
+))
+
 # Required for the toolchain
 define Require/working-make
        echo 'all: test' > $(TMP_DIR)/check.mk