add package/openwrt-packages to .gitignore
[openwrt-10.03/.git] / include / prereq-build.mk
index e90c3157b050a5e1ebc9097ac6855f5dcf799480..b0114f0b9e0a9b4e3a75e040c2de546afcda1496 100644 (file)
@@ -7,25 +7,34 @@
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
+include $(INCLUDE_DIR)/host.mk
+
+PKG_NAME:=Build dependency
 
 define Require/non-root
        [ "$$(shell whoami)" != "root" ]
 endef
 $(eval $(call Require,non-root, \
-       Building OpenWrt as root is not supported! \
+       Please do not compile as root. \
 ))
 
 # Required for the toolchain
 define Require/working-make
-       echo 'all: test' > $(TMP_DIR)/check.mk
-       echo 'e0 = $$$$(foreach s,foobar,$$$$(eval $$$$s:))' >> $(TMP_DIR)/check.mk
-       echo 'e1 = $$$$(foreach s,foobar, $$$$(eval $$$$s:))' >> $(TMP_DIR)/check.mk
-       echo 'test: $$$$(strip $$$$(e0)) $$$$(strip $$$$(e1))' >> $(TMP_DIR)/check.mk
-       $(NO_TRACE_MAKE) -f $(TMP_DIR)/check.mk
+       $(MAKE) -v | awk '($$$$1 == "GNU") && ($$$$2 = "Make") && ($$$$3 >= "3.81") { print "ok" }' | grep ok > /dev/null
 endef
 
 $(eval $(call Require,working-make, \
-       Your make version is buggy. Please install GNU make v3.81 or later. \
+       Please install GNU make v3.81 or later. (This version has bugs) \
+))
+
+define Require/case-sensitive-fs
+       rm -f $(TMP_DIR)/test.*
+       touch $(TMP_DIR)/test.fs
+       [ \! -f $(TMP_DIR)/test.FS ]
+endef
+
+$(eval $(call Require,case-sensitive-fs, \
+       OpenWrt can only be built on a case-sensitive filesystem \
 ))
 
 define Require/working-gcc
@@ -34,16 +43,17 @@ define Require/working-gcc
 endef
 
 $(eval $(call Require,working-gcc, \
-       No working GNU C Compiler (gcc) was found on your system. \
+       Please install the GNU C Compiler (gcc). \
 ))
 
 define Require/working-g++
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ -
+               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ - && \
+               $(TMP_DIR)/a.out
 endef
 
 $(eval $(call Require,working-g++, \
-       No working GNU C++ Compiler (g++) was found on your system. \
+       Please install the GNU C++ Compiler (g++). \
 ))
 
 define Require/ncurses
@@ -52,7 +62,7 @@ define Require/ncurses
 endef
 
 $(eval $(call Require,ncurses, \
-       No ncurses development files were not found on your system. \
+       Please install ncurses. (Missing libncurses.so or ncurses.h) \
 ))
 
 
@@ -62,9 +72,12 @@ define Require/zlib
 endef
 
 $(eval $(call Require,zlib, \
-       No zlib development files were not found on your system. \
+       Please install zlib. (Missing libz.so or zlib.h) \
 ))
 
+$(eval $(call RequireCommand,gawk, \
+       Please install GNU awk. \
+))
 
 $(eval $(call RequireCommand,bison, \
        Please install GNU bison. \
@@ -74,10 +87,6 @@ $(eval $(call RequireCommand,flex, \
        Please install flex. \
 ))
 
-$(eval $(call RequireCommand,python, \
-       Please install python. \
-))
-
 $(eval $(call RequireCommand,unzip, \
        Please install unzip. \
 ))
@@ -93,3 +102,31 @@ $(eval $(call RequireCommand,patch, \
 $(eval $(call RequireCommand,perl, \
        Please install perl. \
 ))
+
+$(eval $(call RequireCommand,wget, \
+       Please install wget. \
+))
+
+define Require/gnutar
+       $(TAR) --version 2>&1 | grep GNU > /dev/null
+endef
+
+$(eval $(call Require,gnutar, \
+       Please install GNU tar. \
+))
+
+$(eval $(call RequireCommand,svn, \
+       Please install the subversion client. \
+))
+
+$(eval $(call RequireCommand,autoconf, \
+       Please install GNU autoconf. \
+))
+
+define Require/gnu-find
+       $(FIND) $(TMP_DIR) -lname foo
+endef
+
+$(eval $(call Require,gnu-find, \
+       Please install GNU find \
+))