clean up and really fix bogus build_ directory
[openwrt-10.03/.git] / include / prereq-build.mk
index a6de9b270aa74d784e70071055cdd1ae10c0d517..a2e5469fa633b62f074f2863797a0056738305ba 100644 (file)
@@ -6,8 +6,16 @@
 #
 
 include $(TOPDIR)/rules.mk
+TMP_DIR:=$(TOPDIR)/tmp
 include $(INCLUDE_DIR)/prereq.mk
 
+define Require/non-root
+       [ "$$(shell whoami)" != "root" ]
+endef
+$(eval $(call Require,non-root, \
+       Please do not compile as root. \
+))
+
 # Required for the toolchain
 define Require/working-make
        echo 'all: test' > $(TMP_DIR)/check.mk
@@ -18,7 +26,7 @@ define Require/working-make
 endef
 
 $(eval $(call Require,working-make, \
-       Your make version is buggy. Please install GNU make v3.81 or later. \
+       Please install GNU make v3.81 or later. (This version has bugs) \
 ))
 
 define Require/working-gcc
@@ -27,7 +35,7 @@ define Require/working-gcc
 endef
 
 $(eval $(call Require,working-gcc, \
-       No working GNU C Compiler (gcc) was found on your system. \
+       Please install the GNU C Compiler (gcc). \
 ))
 
 define Require/working-g++
@@ -36,7 +44,7 @@ define Require/working-g++
 endef
 
 $(eval $(call Require,working-g++, \
-       No working GNU C++ Compiler (g++) was found on your system. \
+       Please install the GNU C++ Compiler (g++). \
 ))
 
 define Require/ncurses
@@ -45,7 +53,7 @@ define Require/ncurses
 endef
 
 $(eval $(call Require,ncurses, \
-       No ncurses development files were not found on your system. \
+       Please install ncurses. (Missing libncurses.so or ncurses.h) \
 ))
 
 
@@ -55,7 +63,7 @@ define Require/zlib
 endef
 
 $(eval $(call Require,zlib, \
-       No zlib development files were not found on your system. \
+       Please install zlib. (Missing libz.so or zlib.h) \
 ))