add kernel_oldconfig target
[openwrt-10.03/.git] / include / prereq-build.mk
index a2e5469fa633b62f074f2863797a0056738305ba..6311e601ba46410bad706961fdac380adc12d81d 100644 (file)
@@ -6,8 +6,10 @@
 #
 
 include $(TOPDIR)/rules.mk
-TMP_DIR:=$(TOPDIR)/tmp
 include $(INCLUDE_DIR)/prereq.mk
+include $(INCLUDE_DIR)/host.mk
+
+PKG_NAME:=Build dependency
 
 define Require/non-root
        [ "$$(shell whoami)" != "root" ]
@@ -29,6 +31,16 @@ $(eval $(call Require,working-make, \
        Please install GNU make v3.81 or later. (This version has bugs) \
 ))
 
+define Require/case-sensitive-fs
+       rm -f $(TMP_DIR)/test.*
+       touch $(TMP_DIR)/test.fs
+       [ \! -f $(TMP_DIR)/test.FS ]
+endef
+
+$(eval $(call Require,case-sensitive-fs, \
+       OpenWrt can only be built on a case-sensitive filesystem \
+))
+
 define Require/working-gcc
        echo 'int main(int argc, char **argv) { return 0; }' | \
                gcc -x c -o $(TMP_DIR)/a.out -
@@ -66,6 +78,9 @@ $(eval $(call Require,zlib, \
        Please install zlib. (Missing libz.so or zlib.h) \
 ))
 
+$(eval $(call RequireCommand,gawk, \
+       Please install GNU awk. \
+))
 
 $(eval $(call RequireCommand,bison, \
        Please install GNU bison. \
@@ -75,10 +90,6 @@ $(eval $(call RequireCommand,flex, \
        Please install flex. \
 ))
 
-$(eval $(call RequireCommand,python, \
-       Please install python. \
-))
-
 $(eval $(call RequireCommand,unzip, \
        Please install unzip. \
 ))
@@ -94,3 +105,20 @@ $(eval $(call RequireCommand,patch, \
 $(eval $(call RequireCommand,perl, \
        Please install perl. \
 ))
+
+$(eval $(call RequireCommand,wget, \
+       Please install wget. \
+))
+
+define Require/gnutar
+       $(TAR) --version 2>&1 | grep GNU > /dev/null
+endef
+
+$(eval $(call Require,gnutar, \
+       Please install GNU tar. \
+))
+
+$(eval $(call RequireCommand,autoconf, \
+       Please install GNU autoconf. \
+))
+