make target/linux/* directories self-contained, use the selected kernel version for...
[openwrt-10.03/.git] / include / prereq-build.mk
index e90c3157b050a5e1ebc9097ac6855f5dcf799480..10bc68ae158585f6a0c54dda6d42c43622378a7e 100644 (file)
@@ -6,13 +6,15 @@
 #
 
 include $(TOPDIR)/rules.mk
+TMP_DIR:=$(TOPDIR)/tmp
 include $(INCLUDE_DIR)/prereq.mk
+include $(INCLUDE_DIR)/host.mk
 
 define Require/non-root
        [ "$$(shell whoami)" != "root" ]
 endef
 $(eval $(call Require,non-root, \
-       Building OpenWrt as root is not supported! \
+       Please do not compile as root. \
 ))
 
 # Required for the toolchain
@@ -25,7 +27,17 @@ define Require/working-make
 endef
 
 $(eval $(call Require,working-make, \
-       Your make version is buggy. Please install GNU make v3.81 or later. \
+       Please install GNU make v3.81 or later. (This version has bugs) \
+))
+
+define Require/case-sensitive-fs
+       rm -f $(TMP_DIR)/test.*
+       touch $(TMP_DIR)/test.fs
+       [ \! -f $(TMP_DIR)/test.FS ]
+endef
+
+$(eval $(call Require,case-sensitive-fs, \
+       OpenWrt can only be built on a case-sensitive filesystem \
 ))
 
 define Require/working-gcc
@@ -34,7 +46,7 @@ define Require/working-gcc
 endef
 
 $(eval $(call Require,working-gcc, \
-       No working GNU C Compiler (gcc) was found on your system. \
+       Please install the GNU C Compiler (gcc). \
 ))
 
 define Require/working-g++
@@ -43,7 +55,7 @@ define Require/working-g++
 endef
 
 $(eval $(call Require,working-g++, \
-       No working GNU C++ Compiler (g++) was found on your system. \
+       Please install the GNU C++ Compiler (g++). \
 ))
 
 define Require/ncurses
@@ -52,7 +64,7 @@ define Require/ncurses
 endef
 
 $(eval $(call Require,ncurses, \
-       No ncurses development files were not found on your system. \
+       Please install ncurses. (Missing libncurses.so or ncurses.h) \
 ))
 
 
@@ -62,7 +74,7 @@ define Require/zlib
 endef
 
 $(eval $(call Require,zlib, \
-       No zlib development files were not found on your system. \
+       Please install zlib. (Missing libz.so or zlib.h) \
 ))
 
 
@@ -93,3 +105,15 @@ $(eval $(call RequireCommand,patch, \
 $(eval $(call RequireCommand,perl, \
        Please install perl. \
 ))
+
+$(eval $(call RequireCommand,wget, \
+       Please install wget. \
+))
+
+define Require/gnutar
+       $(TAR) --version 2>&1 | grep GNU > /dev/null
+endef
+
+$(eval $(call Require,gnutar, \
+       Please install GNU tar. \
+))