large improvement for parallel builds. works without V=99 now and without warnings...
[openwrt-10.03/.git] / include / package.mk
index 74ad47874771d6152bc488741ffc21cf3792e6b9..da8de5cccfdac4daf26ab264e5eb05b7c75b96f2 100644 (file)
@@ -83,7 +83,7 @@ define Build/DefaultTargets
        touch $$@
 
   $(STAMP_INSTALLED): $(STAMP_BUILT)
-       $(SUBMAKE) clean-staging
+       $(SUBMAKE) -j1 clean-staging
        rm -rf $(TMP_DIR)/stage-$(PKG_NAME)
        mkdir -p $(TMP_DIR)/stage-$(PKG_NAME)/host $(STAGING_DIR)/packages $(STAGING_DIR_HOST)/packages
        $(call Build/InstallDev,$(TMP_DIR)/stage-$(PKG_NAME),$(TMP_DIR)/stage-$(PKG_NAME)/host)