changed pkg_install_files so one can specify the folder to install from
[openwrt-10.03/.git] / include / package.mk
index 6307a1f47c2b41a1235298bd03b5d9e4d9e543f1..d90bec8872525bde3a30f62e746c3d2be76ff291 100644 (file)
@@ -122,7 +122,7 @@ define libtool_fixup_libdir
 endef
 
 define pkg_install_files
-       $(foreach install_file,$(2),$(INSTALL_DIR) $(1)/`dirname $(install_file)`; $(CP) $(PKG_INSTALL_DIR)/$(install_file) $(1)/`dirname $(install_file)`;)
+       $(foreach install_file,$(3),$(INSTALL_DIR) $(2)/`dirname $(install_file)`; $(CP) $(1)/$(install_file) $(2)/`dirname $(install_file)`;)
 endef
 
 define Build/Prepare