minor makefile tweaks
[openwrt-10.03/.git] / include / package.mk
index cf8756ea63ecb58811947b07509099222913702c..3dc944dbfa0a21774866fd1e0027c91f5ae7d18f 100644 (file)
@@ -1,19 +1,25 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 ifneq ($(DUMP),)
   all: dumpinfo
 else
   all: compile
 endif
 
+include $(INCLUDE_DIR)/prereq.mk
+
 define Build/DefaultTargets
   ifeq ($(DUMP),)
-    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),$(PKG_BUILD_DIR))
-      ifeq ($(CONFIG_AUTOREBUILD),y)
+    ifeq ($(CONFIG_AUTOREBUILD),y)
+      ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),$(PKG_BUILD_DIR))
         $(PKG_BUILD_DIR)/.prepared: package-clean
       endif
-    endif
 
-    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
-      ifeq ($(CONFIG_AUTOREBUILD),y)
+      ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg $(IPKG_$(1)) $(PKG_BUILD_DIR)),$(IPKG_$(1)))
         $(PKG_BUILD_DIR)/.built: package-rebuild
       endif
     endif
@@ -34,18 +40,19 @@ define Build/DefaultTargets
        $(call Build/Compile)
        touch $$@
 
-  $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed: $(PKG_BUILD_DIR)/.built
+  ifdef Build/InstallDev
+    $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed: $(PKG_BUILD_DIR)/.built
+       mkdir -p $(STAGING_DIR)/stampfiles
        $(call Build/InstallDev)
        touch $$@
        
-  ifdef Build/InstallDev
     compile-targets: $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
   endif
 
   package-clean: FORCE
        $(call Build/Clean)
        $(call Build/UninstallDev)
-       rm -f $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
+       -rm -f $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
 
   package-rebuild: FORCE
        @-rm -f $(PKG_BUILD_DIR)/.built
@@ -59,6 +66,7 @@ define Package/Default
   SECTION:=opt
   CATEGORY:=Extra packages
   DEPENDS:=
+  EXTRA_DEPENDS:=
   MAINTAINER:=OpenWrt Developers Team <openwrt-devel@openwrt.org>
   SOURCE:=$(patsubst $(TOPDIR)/%,%,${shell pwd})
   ifneq ($(PKG_VERSION),)
@@ -74,14 +82,16 @@ define Package/Default
   PRIORITY:=optional
   DEFAULT:=
   MENU:=
+  SUBMENU:=
+  SUBMENUDEP:=
   TITLE:=
   DESCRIPTION:=
 endef
 
 define BuildIPKGVariable
-pkg_$(subst .,_,$(subst -,_,$(1)))_$(2) = $$(Package/$(1)/$(2))
-export pkg_$(subst .,_,$(subst -,_,$(1))_$(2))
-$(1)_COMMANDS += if [ -n "$$$$$$$$pkg_$(subst .,_,$(subst -,_,$(1)))_$(2)" ]; then echo "$$$$$$$$pkg_$(subst .,_,$(subst -,_,$(1)))_$(2)" > $(2); fi;
+  pkg_$(subst .,_,$(subst -,_,$(1)))_$(2) = $$(Package/$(1)/$(2))
+  export pkg_$(subst .,_,$(subst -,_,$(1))_$(2))
+  $(1)_COMMANDS += if [ -n "$$$$$$$$pkg_$(subst .,_,$(subst -,_,$(1)))_$(2)" ]; then echo "$$$$$$$$pkg_$(subst .,_,$(subst -,_,$(1)))_$(2)" > $(2); fi;
 endef
 
 define BuildPackage
@@ -106,30 +116,46 @@ define BuildPackage
   IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
   INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
 
-  ifeq ($(CONFIG_PACKAGE_$(1)),y)
-    install-targets: $$(INFO_$(1))
+  ifdef Package/$(1)/install
+    ifeq ($(CONFIG_PACKAGE_$(1)),y)
+      install-targets: $$(INFO_$(1))
+    endif
+
+    ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER),)
+      compile-targets: $$(IPKG_$(1))
+    endif
   endif
 
-  ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER),)
-    compile-targets: $$(IPKG_$(1))
+  ifeq ($(FORCEREBUILD),y)
+    $$(IPKG_$(1)): FORCE
   endif
 
   IDEPEND_$(1):=$$(strip $$(DEPENDS))
 
-  DUMPINFO += \
+  ifneq ($(DUMP),)
+    DUMPINFO += \
        echo "Package: $(1)"; 
 
-  ifneq ($(MENU),)
-    DUMPINFO += \
+    ifneq ($(MENU),)
+      DUMPINFO += \
        echo "Menu: $(MENU)";
-  endif
+    endif
 
-  ifneq ($(DEFAULT),)
-    DUMPINFO += \
+    ifneq ($(SUBMENU),)
+      DUMPINFO += \
+       echo "Submenu: $(SUBMENU)";
+      ifneq ($(SUBMENUDEP),)
+        DUMPINFO += \
+         echo "Submenu-Depends: $(SUBMENUDEP)";
+      endif
+    endif
+
+    ifneq ($(DEFAULT),)
+      DUMPINFO += \
        echo "Default: $(DEFAULT)";
-  endif
+    endif
 
-  DUMPINFO += \
+    DUMPINFO += \
        echo "Version: $(VERSION)"; \
        echo "Depends: $$(IDEPEND_$(1))"; \
        echo "Build-Depends: $(PKG_BUILDDEP)"; \
@@ -137,19 +163,20 @@ define BuildPackage
        echo "Title: $(TITLE)"; \
        echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g';
 
-  ifneq ($(URL),)
-    DUMPINFO += \
+    ifneq ($(URL),)
+      DUMPINFO += \
        echo; \
        echo "$(URL)";
-  endif
+    endif
 
-  DUMPINFO += \
+    DUMPINFO += \
        echo "@@";
 
-  ifneq ($(CONFIG),)
-    DUMPINFO += \
+    ifneq ($(CONFIG),)
+      DUMPINFO += \
        echo "Config: $(CONFIG)" | sed -e 's,\\,\n,g'; \
        echo "@@";
+    endif
   endif
 
   $(eval $(call BuildIPKGVariable,$(1),conffiles))
@@ -157,7 +184,7 @@ define BuildPackage
   $(eval $(call BuildIPKGVariable,$(1),postinst))
   $(eval $(call BuildIPKGVariable,$(1),prerm))
   $(eval $(call BuildIPKGVariable,$(1),postrm))
-  $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
+  $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH)
        mkdir -p $$(IDIR_$(1))/CONTROL
        echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
        echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
@@ -166,7 +193,7 @@ define BuildPackage
                for depend in $$(filter-out @%,$$(IDEPEND_$(1))); do \
                        DEPENDS=$$$${DEPENDS:+$$$$DEPENDS, }$$$${depend##+}; \
                done; \
-               echo "Depends: $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
+               echo "Depends: $(EXTRA_DEPENDS) $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
        )
        echo "Source: $(SOURCE)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Section: $(SECTION)" >> $$(IDIR_$(1))/CONTROL/control
@@ -179,7 +206,7 @@ define BuildPackage
                $($(1)_COMMANDS) \
        )
 
-  $$(IPKG_$(1)): $$(IDIR_$(1))/CONTROL/control $(PKG_BUILD_DIR)/.built
+  $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
        -find $$(IDIR_$(1)) -name CVS | xargs rm -rf
@@ -187,6 +214,7 @@ define BuildPackage
        -find $$(IDIR_$(1)) -name '.#*' | xargs rm -f
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
+       @[ -f $$(IPKG_$(1)) ] || false 
 
   $$(INFO_$(1)): $$(IPKG_$(1))
        $(IPKG) install $$(IPKG_$(1))
@@ -196,8 +224,11 @@ define BuildPackage
 
   clean: $(1)-clean
 
-  $$(eval $$(call Build/DefaultTargets,$(1)))
+  $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH): $(PKG_BUILD_DIR)/.prepared
+       -rm $(PKG_BUILD_DIR)/.version-$(1)_*
+       @touch $$@
 
+  $$(eval $$(call Build/DefaultTargets,$(1)))
 endef
 
 ifneq ($(strip $(PKG_CAT)),)
@@ -274,7 +305,7 @@ else
        mkdir -p $@
                
   ifneq ($(strip $(PKG_SOURCE)),)
-    source: $(DL_DIR)/$(PKG_SOURCE)
+    download: $(DL_DIR)/$(PKG_SOURCE)
 
     $(DL_DIR)/$(PKG_SOURCE):
                mkdir -p $(DL_DIR)
@@ -283,7 +314,7 @@ else
     $(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)
   endif
 
-  source:
+  download:
   prepare: $(PKG_BUILD_DIR)/.prepared
   configure: $(PKG_BUILD_DIR)/.configured