add 'reset to defaults' to menuconfig
[openwrt-10.03/.git] / include / package.mk
index 82298b02498677b08c81a001b24f01f414e8d803..0996574d26dd8a6cfab9fb1fd84920c4fea8438d 100644 (file)
@@ -6,7 +6,7 @@ endif
 
 define Build/DefaultTargets
   ifeq ($(DUMP),)
-    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . $(TOPDIR)/package/rules.mk),$(PKG_BUILD_DIR))
+    ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) .),$(PKG_BUILD_DIR))
       ifeq ($(CONFIG_AUTOREBUILD),y)
         $(PKG_BUILD_DIR)/.prepared: package-clean
       endif
@@ -74,6 +74,7 @@ define Package/Default
   PRIORITY:=optional
   DEFAULT:=
   MENU:=
+  SUBMENU:=
   TITLE:=
   DESCRIPTION:=
 endef
@@ -124,6 +125,11 @@ define BuildPackage
        echo "Menu: $(MENU)";
   endif
 
+  ifneq ($(SUBMENU),)
+    DUMPINFO += \
+       echo "Submenu: $(SUBMENU)";
+  endif
+
   ifneq ($(DEFAULT),)
     DUMPINFO += \
        echo "Default: $(DEFAULT)";
@@ -201,14 +207,15 @@ define BuildPackage
 endef
 
 ifneq ($(strip $(PKG_CAT)),)
+  ifeq ($(PKG_CAT),unzip)
+    UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
+  else
+    UNPACK=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
+  endif
   define Build/Prepare/Default
-       @if [ "$(PKG_CAT)" = "unzip" ]; then \
-               unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE) ; \
-       else \
-               $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) - ; \
-       fi                                                
+       $(UNPACK)
        @if [ -d ./patches ]; then \
-               $(PATCH) $(PKG_BUILD_DIR) ./patches ; \
+               $(PATCH) $(PKG_BUILD_DIR) ./patches; \
        fi
   endef
 endif