Use find -exec instead of xargs
[openwrt-10.03/.git] / include / package-ipkg.mk
index 0f98dcfe14ece399fc043c026e9f78a308f0ca43..d824d268f4127ca153f2ee2d175dc203d4ce58de 100644 (file)
@@ -11,38 +11,41 @@ define BuildIPKGVariable
 endef
 
 ifeq ($(DUMP),)
-define BuildIPKG
-  IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
-  IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
-  INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
+  define BuildIPKG
+    IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
+    IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
+    INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
 
-  ifdef Package/$(1)/install
-    ifeq ($(CONFIG_PACKAGE_$(1)),y)
-      install: $$(INFO_$(1))
-    endif
+    ifdef Package/$(1)/install
+      ifneq ($(CONFIG_PACKAGE_$(1))$(SDK)$(DEVELOPER),)
+        compile: $$(IPKG_$(1))
 
-    ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER)$(SDK),)
-      compile: $$(IPKG_$(1))
-    else
-      compile: $(1)-disabled
-      $(1)-disabled:
-       @echo "WARNING: skipping $(1) -- package not selected"
-    endif
-  endif
+        ifeq ($(CONFIG_PACKAGE_$(1)),y)
+          install: $$(INFO_$(1))
+        endif
 
-  ifeq ($(FORCEREBUILD),y)
-    $$(IPKG_$(1)): FORCE
-  endif
+        ifneq ($(MAKECMDGOALS),prereq)
+          ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install '$$(IPKG_$(1))' '$(PKG_BUILD_DIR)'),$$(IPKG_$(1)))
+            $(PKG_BUILD_DIR)/.built: package-rebuild
+            $$(info Rebuilding $(subst $(TOPDIR)/,,$$(IPKG_$(1))))
+          endif
+        endif
 
-  IDEPEND_$(1):=$$(strip $$(DEPENDS))
+      else
+        compile: $(1)-disabled
+        $(1)-disabled:
+               @echo "WARNING: skipping $(1) -- package not selected"
+      endif
+    endif
 
+    IDEPEND_$(1):=$$(strip $$(DEPENDS))
   
-  $(eval $(call BuildIPKGVariable,$(1),conffiles))
-  $(eval $(call BuildIPKGVariable,$(1),preinst))
-  $(eval $(call BuildIPKGVariable,$(1),postinst))
-  $(eval $(call BuildIPKGVariable,$(1),prerm))
-  $(eval $(call BuildIPKGVariable,$(1),postrm))
-  $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH)
+    $(eval $(call BuildIPKGVariable,$(1),conffiles))
+    $(eval $(call BuildIPKGVariable,$(1),preinst))
+    $(eval $(call BuildIPKGVariable,$(1),postinst))
+    $(eval $(call BuildIPKGVariable,$(1),prerm))
+    $(eval $(call BuildIPKGVariable,$(1),postrm))
+    $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH)
        @rm -f $(PACKAGE_DIR)/$(1)_*
        mkdir -p $$(IDIR_$(1))/CONTROL
        echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
@@ -52,9 +55,7 @@ define BuildIPKG
                for depend in $$(filter-out @%,$$(IDEPEND_$(1))); do \
                        DEPENDS=$$$${DEPENDS:+$$$$DEPENDS, }$$$${depend##+}; \
                done; \
-               echo "Depends: $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
-       )
-       ( \
+               echo "Depends: $$$$DEPENDS"; \
                echo "Source: $(SOURCE)"; \
                echo "Section: $(SECTION)"; \
                echo "Priority: $(PRIORITY)"; \
@@ -67,41 +68,29 @@ define BuildIPKG
                $($(1)_COMMANDS) \
        )
 
-  $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
+    $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
-       -find $$(IDIR_$(1)) -name CVS | xargs rm -rf
-       -find $$(IDIR_$(1)) -name .svn | xargs rm -rf
-       -find $$(IDIR_$(1)) -name '.#*' | xargs rm -f
+       -find $$(IDIR_$(1)) -name CVS   -exec rm -rf {} \;
+       -find $$(IDIR_$(1)) -name .svn  -exec rm -rf {} \;
+       -find $$(IDIR_$(1)) -name '.#*' -exec rm -f  {} \;
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
        @[ -f $$(IPKG_$(1)) ] || false 
 
-  $$(INFO_$(1)): $$(IPKG_$(1))
+    $$(INFO_$(1)): $$(IPKG_$(1))
        $(IPKG) install $$(IPKG_$(1))
 
-  $(1)-clean:
+    $(1)-clean:
        rm -f $(PACKAGE_DIR)/$(1)_*
 
-  clean: $(1)-clean
+    clean: $(1)-clean
 
-  $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH): $(PKG_BUILD_DIR)/.prepared
+    $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH): $(PKG_BUILD_DIR)/.prepared
        -@rm -f $(PKG_BUILD_DIR)/.version-$(1)_* 2>/dev/null
        @touch $$@
 
-  $$(eval $$(call Build/DefaultTargets,$(1)))
+    $$(eval $$(call Build/DefaultTargets,$(1)))
 
-  ifdef Package/$(1)/install
-    ifneq ($$(CONFIG_PACKAGE_$(1))$(DEVELOPER)$(SDK),)
-      ifneq ($(MAKECMDGOALS),prereq)
-        ifneq ($(DUMP),1)
-          ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install '$$(IPKG_$(1))' '$(PKG_BUILD_DIR)'),$$(IPKG_$(1)))
-            $(PKG_BUILD_DIR)/.built: package-rebuild
-            $$(info Rebuilding $(subst $(TOPDIR)/,,$$(IPKG_$(1))))
-          endif
-        endif
-      endif
-    endif
-  endif
-endef
+  endef
 endif