clean up dependency handling for autorebuilds
[openwrt-10.03/.git] / include / package-ipkg.mk
index 86c802289c34d38556a6360243657cac18ca5043..ac6912844b029300318035a6523fef094ef1dd4a 100644 (file)
@@ -23,14 +23,6 @@ ifeq ($(DUMP),)
         ifeq ($(CONFIG_PACKAGE_$(1)),y)
           install: $$(INFO_$(1))
         endif
-
-        ifneq ($(MAKECMDGOALS),prereq)
-          ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install '$$(IPKG_$(1))' '$(PKG_BUILD_DIR)'),$$(IPKG_$(1)))
-            $(PKG_BUILD_DIR)/.built: package-rebuild
-            $$(info Rebuilding $(subst $(TOPDIR)/,,$$(IPKG_$(1))))
-          endif
-        endif
-
       else
         compile: $(1)-disabled
         $(1)-disabled: