build: do not use shell calls to export empty opkg control files, speeds up package...
[openwrt-10.03/.git] / include / package-ipkg.mk
index cc1c8eb1315bb64e9ba3d568691895251896cc65..0dd398e1baa35f1a1997981857bac833dab19b8c 100644 (file)
@@ -16,6 +16,7 @@ OPKG:= \
        --force-depends \
        --force-overwrite \
        --force-postinstall \
+       --force-maintainer \
        --add-dest root:/ \
        --add-arch all:100 \
        --add-arch $(ARCH_PACKAGES):200
@@ -27,8 +28,10 @@ IPKG_BUILD:= \
 IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/opkg
 
 define BuildIPKGVariable
+ifdef Package/$(1)/$(2)
   $(call shexport,Package/$(1)/$(2))
   $(1)_COMMANDS += var2file "$(call shvar,Package/$(1)/$(2))" $(2);
+endif
 endef
 
 PARENL :=(