port over the netfilter module packaging to the new system and fix iptables dependencies
[openwrt-10.03/.git] / include / netfilter.mk
index 236d4b2429f64b15f6c1c5f4de4ef79daa121417..d4ec0f3915db9e7fd4b19537968cf16bdf57e017 100644 (file)
@@ -6,12 +6,9 @@
 #
 # $Id: netfilter.mk 2411 2005-11-11 03:41:43Z nico $
 
-ifeq ($(NF_2_6),1)
+ifeq ($(NF_KMOD),1)
 P_V4:=ipv4/netfilter/
 P_XT:=netfilter/
-else
-P_V4:=
-P_XT:=
 endif
 
 IPT_CONNTRACK-m :=
@@ -84,6 +81,7 @@ IPT_NAT-$(CONFIG_IP_NF_NAT) += $(P_V4)ipt_SNAT $(P_V4)ipt_DNAT
 IPT_NAT-$(CONFIG_IP_NF_TARGET_MASQUERADE) += $(P_V4)ipt_MASQUERADE
 IPT_NAT-$(CONFIG_IP_NF_TARGET_MIRROR) += $(P_V4)ipt_MIRROR
 IPT_NAT-$(CONFIG_IP_NF_TARGET_REDIRECT) += $(P_V4)ipt_REDIRECT
+IPT_NAT-$(CONFIG_IP_NF_TARGET_NETMAP) += $(P_V4)ipt_NETMAP
 
 IPT_NAT_EXTRA-m := 
 IPT_NAT_EXTRA-$(CONFIG_IP_NF_AMANDA) += $(P_V4)ip_conntrack_amanda