minor cleanup
[openwrt-10.03/.git] / include / kernel.mk
index 4b5fe72f0097ec11591644bfe46c44397215ff6e..bd558ceec731f4335940253ea59c05da5b126f77 100644 (file)
@@ -16,7 +16,7 @@ else
   # check to see if .kernel.mk matches target.mk
   ifeq ($(CONFIG_BOARD)-$(CONFIG_KERNEL),$(BOARD)-$(KERNEL))
      LINUX_VERSION:=$(CONFIG_LINUX_VERSION)
-     RELEASE:=$(CONFIG_RELEASE)
+     LINUX_RELEASE:=$(CONFIG_LINUX_RELEASE)
   else
   # oops, old .kernel.config; rebuild it (hiding the misleading errors this produces)
     $(warning rebuilding .kernel.mk)
@@ -38,10 +38,13 @@ else
        -e 's/armeb/arm/' \
   )
 
-  KERNELNAME=""
+  KERNELNAME=
   ifneq (,$(findstring x86,$(BOARD)))
     KERNELNAME="bzImage"
   endif
+  ifneq (,$(findstring ppc,$(BOARD)))
+    KERNELNAME="uImage"
+  endif
 
   ifneq (,$(findstring uml,$(BOARD)))
     LINUX_KARCH:=um