cleanup/rewrite of the kernel build process
[openwrt-10.03/.git] / include / kernel.mk
index 42c9cdf3a14c9e52fd9fcb8e6e07ea2b657711e2..1ab85d4cc58a708be42c5c81363beef5b4e43826 100644 (file)
@@ -18,12 +18,11 @@ else
      LINUX_VERSION:=$(CONFIG_LINUX_VERSION)
      LINUX_RELEASE:=$(CONFIG_LINUX_RELEASE)
      LINUX_KARCH:=$(CONFIG_LINUX_KARCH)
-  else 
-  # oops, old .kernel.config; rebuild it (hiding the misleading errors this produces)
-    $(warning rebuilding .kernel.mk)
-    $(TOPDIR)/.kernel.mk: FORCE
+  else
     ifneq ($(KERNEL_BUILD),1)
-      $(TOPDIR)/.kernel.mk:
+      # oops, old .kernel.config; rebuild it (hiding the misleading errors this produces)
+      $(warning rebuilding .kernel.mk)
+      $(TOPDIR)/.kernel.mk: FORCE
                @$(MAKE) -C $(TOPDIR)/target/linux/$(BOARD)-$(KERNEL) $@ &>/dev/null
     endif
   endif