major target cleanup. it is now possible to have subtargets that can override many...
[openwrt-10.03/.git] / include / kernel-version.mk
index ee3486fdb102487761cf9ec073098a86fa243359..508cf9934a5c72d0f4ae75d9e41b05067b4c281a 100644 (file)
@@ -1,11 +1,9 @@
 # Use the default kernel version if the Makefile doesn't override it
 
-ifeq ($(LINUX_VERSION),)
-  ifeq ($(KERNEL),2.4)
-    LINUX_VERSION:=2.4.34
-  else
-    LINUX_VERSION:=2.6.21.5
-  endif
+ifeq ($(KERNEL),2.4)
+  LINUX_VERSION?=2.4.34
+else
+  LINUX_VERSION?=2.6.21.5
 endif
 LINUX_RELEASE?=1
 
@@ -22,6 +20,6 @@ endif
 # disable the md5sum check for unknown kernel versions
 LINUX_KERNEL_MD5SUM?=x
 
-KERNEL:=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
-KERNEL_PATCHVER:=$(shell echo $(LINUX_VERSION) | cut -d. -f1,2,3 | cut -d- -f1)
+KERNEL?=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
+KERNEL_PATCHVER=$(shell echo $(LINUX_VERSION) | cut -d. -f1,2,3 | cut -d- -f1)