large improvement for parallel builds. works without V=99 now and without warnings...
[openwrt-10.03/.git] / include / kernel-build.mk
index 82b0bcff27af7e023a11be3a49bf2e73fe82ab72..75c2bcf01aacbedcd5699638c5836db28c9037b3 100644 (file)
@@ -7,10 +7,6 @@
 include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/prereq.mk
 
-ifneq ($(DUMP),1)
-  override MAKEFLAGS=
-endif
-
 ifneq ($(DUMP),1)
   all: compile
 endif
@@ -48,6 +44,7 @@ define Download/kernel
 endef
 
 define BuildKernel
+  $(if $(QUILT),$(Build/Quilt))
   $(if $(LINUX_SITE),$(call Download,kernel))
 
   $(STAMP_PREPARED): $(DL_DIR)/$(LINUX_SOURCE)
@@ -81,6 +78,7 @@ define BuildKernel
 
   oldconfig menuconfig: $(STAMP_PREPARED) FORCE
        $(LINUX_CONFCMD) > $(LINUX_DIR)/.config
+       touch $(LINUX_CONFIG)
        $(MAKE) -C $(LINUX_DIR) $(KERNEL_MAKEOPTS) $$@
        $(SCRIPT_DIR)/kconfig.pl '>' $(GENERIC_LINUX_CONFIG) $(LINUX_DIR)/.config > $(LINUX_CONFIG)
        $(Kernel/Configure)
@@ -99,7 +97,7 @@ define BuildKernel
        @$(MAKE) compile
 
   image-prereq:
-       $(SUBMAKE) -s -C image prereq TARGET_BUILD=
+       @$(NO_TRACE_MAKE) -s -C image prereq TARGET_BUILD=
 
   prereq: image-prereq