build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail...
[openwrt-10.03/.git] / include / kernel-build.mk
index da1fe39bcaed9149c296e725615df19760983a0f..8750bb4fd52487b98dfb6d24cabb7ddbc749cf7a 100644 (file)
@@ -167,6 +167,8 @@ $(eval $(call shexport,Target/Description))
 download: $(DL_DIR)/$(LINUX_SOURCE)
 prepare: $(STAMP_CONFIGURED)
 compile: $(LINUX_DIR)/.modules
+       $(MAKE) -C image compile
+
 oldconfig menuconfig: $(STAMP_PREPARED) FORCE
        $(call Kernel/Configure)
        $(SCRIPT_DIR)/config.pl '+' $(GENERIC_LINUX_CONFIG) $(LINUX_CONFIG) > $(LINUX_DIR)/.config