Use find -exec instead of xargs
[openwrt-10.03/.git] / include / image.mk
index 78e1a2fdc80562cc20f0efbb72d4376b21301b09..eb59ea651cd84e3fdc7f31f42a84f4375dcfe153 100644 (file)
@@ -79,9 +79,9 @@ endif
 
 
 define Image/mkfs/prepare/default
-       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs chmod 0644
-       find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
-       find $(BUILD_DIR)/root -type d | xargs chmod 0755
+       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' -exec chmod 0644 {} \;
+       find $(BUILD_DIR)/root -type f -perm +0100 -exec chmod 0755 {} \;
+       find $(BUILD_DIR)/root -type d -exec chmod 0755 {} \;
        mkdir -p $(BUILD_DIR)/root/tmp
        chmod 0777 $(BUILD_DIR)/root/tmp
 endef