Build bzImage for x86 builds - allow ext2 images even if initramfs used, they are...
[openwrt-10.03/.git] / include / image.mk
index ba3cfb8afa9968232416d83f0430d521d33d9273..903c27ba6333d52376cbcd5de20f2094c5e2429b 100644 (file)
@@ -45,15 +45,17 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
     endef
   endif
   
-  ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
-    define Image/mkfs/ext2
-               $(STAGING_DIR)/bin/genext2fs -q -b 4096 -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
-               $(call Image/Build,ext2)
-    endef
-  endif
   
 endif
 
+ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
+  define Image/mkfs/ext2
+               $(STAGING_DIR)/bin/genext2fs -q -b 8192 -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
+               $(call Image/Build,ext2)
+  endef
+endif
+
+
 define Image/mkfs/prepare/default
        find $(BUILD_DIR)/root -type f -not -perm +0100 | xargs chmod 0644
        find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755