add missing include
[openwrt-10.03/.git] / include / image.mk
index 13b722981a7df29807b11a39ac78793c4888034d..6805389d72529197c8bf5d98889fedb8a7abd46c 100644 (file)
@@ -4,6 +4,8 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
+include $(INCLUDE_DIR)/kernel.mk
 KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
 
 ifneq ($(CONFIG_BIG_ENDIAN),y)
@@ -50,7 +52,7 @@ endif
 
 
 ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
-  E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_SIZE)*1024)))
+  E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))
   
   define Image/mkfs/ext2
                $(STAGING_DIR)/bin/genext2fs -q -b $(E2SIZE) -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2