fix HOST_ARCH and GNU_HOST_NAME for freebsd and other operating systems
[openwrt-10.03/.git] / include / host.mk
index b4580e2b7a5376b9729e2856331e1c06b2a4c075..abcf045d01e05327408dcb6e9bc8310b695ee74d 100644 (file)
@@ -8,17 +8,20 @@
 include $(TOPDIR)/.host.mk
 
 $(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
-       echo "HOST_OS:=`uname`" > $@
-       echo "HOST_ARCH:=` \
-               $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
-                       -e 's/sparc.*/sparc/' \
-                       -e 's/arm.*/arm/' \
-                       -e 's/m68k.*/m68k/' \
-                       -e 's/ppc/powerpc/' \
-                       -e 's/v850.*/v850/' \
-                       -e 's/sh[234]/sh/' \
-                       -e 's/mips-.*/mips/' \
-                       -e 's/mipsel-.*/mipsel/' \
-                       -e 's/cris.*/cris/' \
-                       -e 's/i[3-9]86/i386/'`" >> $@
-       echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
+       @( \
+               HOST_OS=`uname`; \
+               case "$$HOST_OS" in \
+                       Linux) HOST_ARCH=`uname -m`;; \
+                       *) HOST_ARCH=`uname -p`;; \
+               esac; \
+               GNU_HOST_NAME=`gcc -dumpmachine`; \
+               [ -n "$$GNU_HOST_NAME" ] || \
+                       GNU_HOST_NAME=`$(SCRIPT_DIR)/config.guess`; \
+               echo "HOST_OS:=$$HOST_OS" > $@; \
+               echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
+               echo "GNU_HOST_NAME:=$$GNU_HOST_NAME" >> $@; \
+               if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
+                       echo "TAR_WILDCARDS:=--wildcards" >> $@; \
+               fi; \
+       )
+