fix HOST_ARCH and GNU_HOST_NAME for freebsd and other operating systems
[openwrt-10.03/.git] / include / host.mk
index 9eee20fcfbe98013a18e57041bd765084c0dc9a2..abcf045d01e05327408dcb6e9bc8310b695ee74d 100644 (file)
@@ -8,21 +8,20 @@
 include $(TOPDIR)/.host.mk
 
 $(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
-       @echo "HOST_OS:=`uname`" > $@
-       @echo "HOST_ARCH:=` \
-               $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
-                       -e 's/sparc.*/sparc/' \
-                       -e 's/arm.*/arm/' \
-                       -e 's/m68k.*/m68k/' \
-                       -e 's/ppc/powerpc/' \
-                       -e 's/v850.*/v850/' \
-                       -e 's/sh[234]/sh/' \
-                       -e 's/mips-.*/mips/' \
-                       -e 's/mipsel-.*/mipsel/' \
-                       -e 's/cris.*/cris/' \
-                       -e 's/i[3-9]86/i386/'`" >> $@
-       @echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
-       @if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
-               echo "TAR_WILDCARDS:=--wildcards" >> $@; \
-       fi
+       @( \
+               HOST_OS=`uname`; \
+               case "$$HOST_OS" in \
+                       Linux) HOST_ARCH=`uname -m`;; \
+                       *) HOST_ARCH=`uname -p`;; \
+               esac; \
+               GNU_HOST_NAME=`gcc -dumpmachine`; \
+               [ -n "$$GNU_HOST_NAME" ] || \
+                       GNU_HOST_NAME=`$(SCRIPT_DIR)/config.guess`; \
+               echo "HOST_OS:=$$HOST_OS" > $@; \
+               echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
+               echo "GNU_HOST_NAME:=$$GNU_HOST_NAME" >> $@; \
+               if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
+                       echo "TAR_WILDCARDS:=--wildcards" >> $@; \
+               fi; \
+       )