don't touch TAR_OPTIONS in host.mk
[openwrt-10.03/.git] / include / host.mk
index b4580e2b7a5376b9729e2856331e1c06b2a4c075..9eee20fcfbe98013a18e57041bd765084c0dc9a2 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/.host.mk
 
 $(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
-       echo "HOST_OS:=`uname`" > $@
-       echo "HOST_ARCH:=` \
+       @echo "HOST_OS:=`uname`" > $@
+       @echo "HOST_ARCH:=` \
                $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
                        -e 's/sparc.*/sparc/' \
                        -e 's/arm.*/arm/' \
@@ -21,4 +21,8 @@ $(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
                        -e 's/mipsel-.*/mipsel/' \
                        -e 's/cris.*/cris/' \
                        -e 's/i[3-9]86/i386/'`" >> $@
-       echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
+       @echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
+       @if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
+               echo "TAR_WILDCARDS:=--wildcards" >> $@; \
+       fi
+