fix verbose output with dash as /bin/sh
[openwrt-10.03/.git] / include / host.mk
index 93f86dce8aafbdc5a3a379455787a657188bc97d..8b2e56ce510bf7c5d9325c755d82a5b6196c9bfc 100644 (file)
@@ -5,24 +5,42 @@
 # See /LICENSE for more information.
 #
 
-include $(TOPDIR)/.host.mk
+-include $(TMP_DIR)/.host.mk
 
-$(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
-       @echo "HOST_OS:=`uname`" > $@
-       @echo "HOST_ARCH:=` \
-               $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
-                       -e 's/sparc.*/sparc/' \
-                       -e 's/arm.*/arm/' \
-                       -e 's/m68k.*/m68k/' \
-                       -e 's/ppc/powerpc/' \
-                       -e 's/v850.*/v850/' \
-                       -e 's/sh[234]/sh/' \
-                       -e 's/mips-.*/mips/' \
-                       -e 's/mipsel-.*/mipsel/' \
-                       -e 's/cris.*/cris/' \
-                       -e 's/i[3-9]86/i386/'`" >> $@
-       @echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
-       @if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
-               echo "TAR_OPTIONS+=--wildcards" >> $@; \
-       fi
+export TAR
+TMP_DIR ?= $(TOPDIR)/tmp
 
+ifneq ($(__host_inc),1)
+__host_inc:=1
+$(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
+       @mkdir -p $(TMP_DIR)
+       @( \
+               HOST_OS=`uname`; \
+               case "$$HOST_OS" in \
+                       Linux) HOST_ARCH=`uname -m`;; \
+                       *) HOST_ARCH=`uname -p`;; \
+               esac; \
+               GNU_HOST_NAME=`gcc -dumpmachine`; \
+               [ -n "$$GNU_HOST_NAME" ] || \
+                       GNU_HOST_NAME=`$(SCRIPT_DIR)/config.guess`; \
+               echo "HOST_OS:=$$HOST_OS" > $@; \
+               echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
+               echo "GNU_HOST_NAME:=$$GNU_HOST_NAME" >> $@; \
+               TAR=`which gtar 2>/dev/null`; \
+               [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar 2>/dev/null`; \
+               echo "TAR:=$$TAR" >> $@; \
+               echo "BASH:=$(shell which bash)" >> $@; \
+               if find -L /tmp -maxdepth 0 >/dev/null 2>/dev/null; then \
+                       echo 'FIND_L=find -L $$(1)' >>$@; \
+               else \
+                       echo 'FIND_L=find $$(1) -follow' >> $@; \
+               fi; \
+       )
+
+endif
+
+ifeq ($(HOST_OS),Linux)
+  XARGS:=xargs -r
+else
+  XARGS:=xargs
+endif