fix verbose output with dash as /bin/sh
[openwrt-10.03/.git] / include / host.mk
index 423ca1661082b53cfd6ce8daf0dd56640a4d884d..8b2e56ce510bf7c5d9325c755d82a5b6196c9bfc 100644 (file)
@@ -5,9 +5,10 @@
 # See /LICENSE for more information.
 #
 
-include $(TMP_DIR)/.host.mk
+-include $(TMP_DIR)/.host.mk
 
 export TAR
+TMP_DIR ?= $(TOPDIR)/tmp
 
 ifneq ($(__host_inc),1)
 __host_inc:=1
@@ -28,10 +29,18 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                TAR=`which gtar 2>/dev/null`; \
                [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar 2>/dev/null`; \
                echo "TAR:=$$TAR" >> $@; \
-               ZCAT=`which gzcat 2>/dev/null`; \
-               [ -n "$$ZCAT" -a -x "$$ZCAT" ] || ZCAT=`which zcat 2>/dev/null`; \
-               echo "ZCAT:=$$ZCAT" >> $@; \
                echo "BASH:=$(shell which bash)" >> $@; \
+               if find -L /tmp -maxdepth 0 >/dev/null 2>/dev/null; then \
+                       echo 'FIND_L=find -L $$(1)' >>$@; \
+               else \
+                       echo 'FIND_L=find $$(1) -follow' >> $@; \
+               fi; \
        )
 
 endif
+
+ifeq ($(HOST_OS),Linux)
+  XARGS:=xargs -r
+else
+  XARGS:=xargs
+endif