move common unpacking code to unpack.mk, replace zcat with $(ZCAT) for systems that...
[openwrt-10.03/.git] / include / host.mk
index 11522184b7ce7f72240493a7b189ed8d229161c9..6c0dcd6699f39d2202d396b6b45fb77838cf4ea9 100644 (file)
@@ -28,5 +28,8 @@ $(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
                if $$TAR --version 2>&1 | grep 'GNU' >/dev/null; then \
                        echo "TAR_WILDCARDS:=--wildcards" >> $@; \
                fi; \
+               ZCAT=`which gzcat`; \
+               [ -n "$$ZCAT" -a -x "$$ZCAT" ] || ZCAT=`which zcat`; \
+               echo "ZCAT:=$$ZCAT" >> $@; \
        )