code to bring in the following for x86:
[openwrt-10.03/.git] / include / host.mk
index 93f86dce8aafbdc5a3a379455787a657188bc97d..3100ce4165a32150d24e3863fa58a49048b1930d 100644 (file)
@@ -7,22 +7,26 @@
 
 include $(TOPDIR)/.host.mk
 
+export TAR
+
 $(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
-       @echo "HOST_OS:=`uname`" > $@
-       @echo "HOST_ARCH:=` \
-               $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
-                       -e 's/sparc.*/sparc/' \
-                       -e 's/arm.*/arm/' \
-                       -e 's/m68k.*/m68k/' \
-                       -e 's/ppc/powerpc/' \
-                       -e 's/v850.*/v850/' \
-                       -e 's/sh[234]/sh/' \
-                       -e 's/mips-.*/mips/' \
-                       -e 's/mipsel-.*/mipsel/' \
-                       -e 's/cris.*/cris/' \
-                       -e 's/i[3-9]86/i386/'`" >> $@
-       @echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
-       @if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
-               echo "TAR_OPTIONS+=--wildcards" >> $@; \
-       fi
+       @( \
+               HOST_OS=`uname`; \
+               case "$$HOST_OS" in \
+                       Linux) HOST_ARCH=`uname -m`;; \
+                       *) HOST_ARCH=`uname -p`;; \
+               esac; \
+               GNU_HOST_NAME=`gcc -dumpmachine`; \
+               [ -n "$$GNU_HOST_NAME" ] || \
+                       GNU_HOST_NAME=`$(SCRIPT_DIR)/config.guess`; \
+               echo "HOST_OS:=$$HOST_OS" > $@; \
+               echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
+               echo "GNU_HOST_NAME:=$$GNU_HOST_NAME" >> $@; \
+               TAR=`which gtar`; \
+               [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar`; \
+               echo "TAR:=$$TAR" >> $@; \
+               ZCAT=`which gzcat`; \
+               [ -n "$$ZCAT" -a -x "$$ZCAT" ] || ZCAT=`which zcat`; \
+               echo "ZCAT:=$$ZCAT" >> $@; \
+       )