[backfire] backport r27648
[openwrt-10.03/.git] / include / host.mk
index cc0436e7b04b42fcd293243b96c02ce5b035810a..02365d9eabdf074a35c6cccc20eeb9bf8709ffd0 100644 (file)
@@ -1,16 +1,31 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
--include $(TMP_DIR)/.host.mk
+TMP_DIR ?= $(TOPDIR)/tmp
+ifeq ($(if $(TARGET_BUILD),,$(DUMP)),)
+  -include $(TMP_DIR)/.host.mk
+endif
 
-export TAR
+export TAR FIND
 
 ifneq ($(__host_inc),1)
 __host_inc:=1
+
+try-run = $(shell set -e; \
+       TMP_F="$(TMP_DIR)/try-run.$$$$.tmp"; \
+       if ($(1)) >/dev/null 2>&1; then echo "$(2)"; else echo "$(3)"; fi; \
+       rm -f "$$TMP_F"; \
+)
+
+host-cc-option = $(call try-run, \
+       $(HOSTCC) $(HOST_CFLAGS) $(1) -c -xc /dev/null -o "$$TMP_F",$(1),$(2) \
+)
+
+.PRECIOUS: $(TMP_DIR)/.host.mk
 $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
        @mkdir -p $(TMP_DIR)
        @( \
@@ -26,20 +41,23 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
                echo "GNU_HOST_NAME:=$$GNU_HOST_NAME" >> $@; \
                TAR=`which gtar 2>/dev/null`; \
+               [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which gnutar 2>/dev/null`; \
                [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar 2>/dev/null`; \
                echo "TAR:=$$TAR" >> $@; \
+               FIND=`which gfind 2>/dev/null`; \
+               [ -n "$$FIND" -a -x "$$FIND" ] || FIND=`which find 2>/dev/null`; \
+               echo "FIND:=$$FIND" >> $@; \
                echo "BASH:=$(shell which bash)" >> $@; \
-               if find -L /tmp -maxdepth 0 >/dev/null 2>/dev/null; then \
-                       echo 'FIND_L=find -L $$(1)' >>$@; \
+               if $$FIND -L /tmp -maxdepth 0 >/dev/null 2>/dev/null; then \
+                       echo "FIND_L=$$FIND -L \$$(1)" >>$@; \
                else \
-                       echo 'FIND_L=find $$(1) -follow' >> $@; \
+                       echo "FIND_L=$$FIND \$$(1) -follow" >> $@; \
+               fi; \
+               if xargs --help 2>&1 | grep 'gnu.org' >/dev/null; then \
+                       echo 'XARGS:=xargs -r' >> $@; \
+               else \
+                       echo 'XARGS:=xargs' >> $@; \
                fi; \
        )
 
 endif
-
-ifeq ($(HOST_OS),Linux)
-  XARGS:=xargs -r
-else
-  XARGS:=xargs
-endif