[backfire] uhttpd: merge r28792
[openwrt-10.03/.git] / include / host.mk
index b93ab8d536d2f0df3e973ea271b1c090dca04264..02365d9eabdf074a35c6cccc20eeb9bf8709ffd0 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,6 +14,17 @@ export TAR FIND
 
 ifneq ($(__host_inc),1)
 __host_inc:=1
+
+try-run = $(shell set -e; \
+       TMP_F="$(TMP_DIR)/try-run.$$$$.tmp"; \
+       if ($(1)) >/dev/null 2>&1; then echo "$(2)"; else echo "$(3)"; fi; \
+       rm -f "$$TMP_F"; \
+)
+
+host-cc-option = $(call try-run, \
+       $(HOSTCC) $(HOST_CFLAGS) $(1) -c -xc /dev/null -o "$$TMP_F",$(1),$(2) \
+)
+
 .PRECIOUS: $(TMP_DIR)/.host.mk
 $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
        @mkdir -p $(TMP_DIR)