[backfire] uhttpd: merge r28792
[openwrt-10.03/.git] / include / host-build.mk
index 57cb3002b5fa0a2dc212e8be32cce760a1b89f57..e02f02371e64b1b18370eac58659aefcadeba14c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -12,7 +12,8 @@ include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/unpack.mk
 include $(INCLUDE_DIR)/depends.mk
 
-HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),)))
+BUILD_TYPES += host
+HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared$(if $(HOST_QUILT)$(DUMP),,$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPENDS),)))
 HOST_STAMP_CONFIGURED:=$(HOST_BUILD_DIR)/.configured
 HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.built
 HOST_STAMP_INSTALLED:=$(STAGING_DIR_HOST)/stamp/.$(PKG_NAME)_installed
@@ -21,6 +22,7 @@ override MAKEFLAGS=
 
 include $(INCLUDE_DIR)/download.mk
 include $(INCLUDE_DIR)/quilt.mk
+include $(INCLUDE_DIR)/autotools.mk
 
 Host/Patch:=$(Host/Patch/Default)
 ifneq ($(strip $(HOST_UNPACK)),)
@@ -35,6 +37,7 @@ define Host/Prepare
 endef
 
 HOST_CONFIGURE_VARS = \
+       CFLAGS="$(HOST_CFLAGS)" \
        CPPFLAGS="$(HOST_CFLAGS)" \
        LDFLAGS="$(HOST_LDFLAGS)" \
        SHELL="$(BASH)"
@@ -53,7 +56,7 @@ HOST_CONFIGURE_ARGS = \
 HOST_CONFIGURE_CMD = ./configure
 
 define Host/Configure/Default
-       @(cd $(HOST_BUILD_DIR)/$(3); \
+       (cd $(HOST_BUILD_DIR)/$(3); \
                if [ -x configure ]; then \
                        $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/$(3)/ && \
                        $(2) \
@@ -77,9 +80,18 @@ define Host/Compile
   $(call Host/Compile/Default)
 endef
 
-ifneq ($(if $(QUILT),,$(CONFIG_AUTOREBUILD)),)
+define Host/Install/Default
+       $(_SINGLE)$(MAKE) -C $(HOST_BUILD_DIR) install
+endef
+
+define Host/Install
+  $(call Host/Install/Default)
+endef
+
+
+ifneq ($(if $(HOST_QUILT),,$(CONFIG_AUTOREBUILD)),)
   define HostHost/Autoclean
-    $(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(HOST_STAMP_PREPARED))
+    $(call rdep,${CURDIR} $(PKG_FILE_DEPENDS),$(HOST_STAMP_PREPARED))
     $(if $(if $(Host/Compile),$(filter prepare,$(MAKECMDGOALS)),1),,$(call rdep,$(HOST_BUILD_DIR),$(HOST_STAMP_BUILT)))
   endef
 endif
@@ -93,36 +105,67 @@ define Download/default
   MD5SUM:=$(PKG_MD5SUM)
 endef
 
+define Host/Exports/Default
+  $(1) : export ACLOCAL_INCLUDE=$$(foreach p,$$(wildcard $$(STAGING_DIR_HOST)/share/aclocal $$(STAGING_DIR_HOST)/share/aclocal-*),-I $$(p))
+  $(1) : export STAGING_PREFIX=$$(STAGING_DIR_HOST)
+  $(1) : export PKG_CONFIG_PATH=$$(STAGING_DIR_HOST)/lib/pkgconfig
+  $(1) : export PKG_CONFIG_LIBDIR=$$(STAGING_DIR_HOST)/lib/pkgconfig
+endef
+Host/Exports=$(Host/Exports/Default)
+
 ifndef DUMP
   define HostBuild
-  $(if $(QUILT),$(Host/Quilt))
-  $(if $(STAMP_PREPARED),,$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
+  $(if $(HOST_QUILT),$(Host/Quilt))
+  $(if $(if $(PKG_HOST_ONLY),,$(STAMP_PREPARED)),,$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
   $(if $(DUMP),,$(call HostHost/Autoclean))
 
   $(HOST_STAMP_PREPARED):
        @-rm -rf $(HOST_BUILD_DIR)
        @mkdir -p $(HOST_BUILD_DIR)
+       $(foreach hook,$(Hooks/HostPrepare/Pre),$(call $(hook))$(sep))
        $(call Host/Prepare)
+       $(foreach hook,$(Hooks/HostPrepare/Post),$(call $(hook))$(sep))
        touch $$@
 
+  $(call Host/Exports,$(HOST_STAMP_CONFIGURED))
   $(HOST_STAMP_CONFIGURED): $(HOST_STAMP_PREPARED)
+       $(foreach hook,$(Hooks/HostConfigure/Pre),$(call $(hook))$(sep))
        $(call Host/Configure)
+       $(foreach hook,$(Hooks/HostConfigure/Post),$(call $(hook))$(sep))
        touch $$@
 
-  $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
-       $(call Host/Compile)
-       touch $$@
-
-  $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT)
-       $(call Host/Install)
-       mkdir -p $$(shell dirname $$@)
-       touch $$@
-
+  $(call Host/Exports,$(HOST_STAMP_BUILT))
   ifdef Host/Install
-    host-install: $(HOST_STAMP_INSTALLED)
+    host-install: $(if $(STAMP_BUILT),$(HOST_STAMP_BUILT),$(HOST_STAMP_INSTALLED))
   endif
 
-  download:
+  ifndef STAMP_BUILT
+    prepare: host-prepare
+    compile: host-compile
+    install: host-install
+    clean: host-clean
+    update: host-update
+
+    $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
+               $(foreach hook,$(Hooks/HostCompile/Pre),$(call $(hook))$(sep))
+               $(call Host/Compile)
+               $(foreach hook,$(Hooks/HostCompile/Post),$(call $(hook))$(sep))
+               touch $$@
+
+    $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT)
+               $(call Host/Install)
+               $(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))
+               mkdir -p $$(shell dirname $$@)
+               touch $$@
+  else
+    $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
+               $(foreach hook,$(Hooks/HostCompile/Pre),$(call $(hook))$(sep))
+               $(call Host/Compile)
+               $(foreach hook,$(Hooks/HostCompile/Post),$(call $(hook))$(sep))
+               $(call Host/Install)
+               $(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))
+               touch $$@
+  endif
   host-prepare: $(HOST_STAMP_PREPARED)
   host-configure: $(HOST_STAMP_CONFIGURED)
   host-compile: $(HOST_STAMP_BUILT)
@@ -134,10 +177,11 @@ ifndef DUMP
 
   endef
 
-  prepare: host-prepare
-  compile: host-compile
-  install: host-install
-  clean: host-clean
+  download:
+  prepare:
+  compile:
+  install:
+  clean:
 
 endif