fix shell escaping bug in append() function
[openwrt-10.03/.git] / include / host-build.mk
index 0d103e2a02b402a102c0aa962cdbe1f48fabb6b4..c19cb8fd1c2cfd257757ee54b033cc758104cf4a 100644 (file)
@@ -1,3 +1,10 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+OS:=$(shell uname)
 ifneq ($(strip $(PKG_CAT)),)
   ifeq ($(PKG_CAT),unzip)
     UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
@@ -58,7 +65,7 @@ endef
 
                
 ifneq ($(strip $(PKG_SOURCE)),)
-  source: $(DL_DIR)/$(PKG_SOURCE)
+  download: $(DL_DIR)/$(PKG_SOURCE)
 
   $(DL_DIR)/$(PKG_SOURCE):
        mkdir -p $(DL_DIR)
@@ -95,7 +102,7 @@ define HostBuild
        $(call Build/Uninstall)
        rm -f $(STAGING_DIR)/stampfiles/.host_$(PKG_NAME)-installed
 
-  source:
+  download:
   prepare: $(PKG_BUILD_DIR)/.prepared
   configure: $(PKG_BUILD_DIR)/.configured