set shell to bash in master makefile
[openwrt-10.03/.git] / include / host-build.mk
index 5670b6f17db78992e10a8a5e95fedeeafb9c29ed..a1287da475bc8a63a5d13c021e6d27efc0fe39e9 100644 (file)
@@ -5,24 +5,7 @@
 # See /LICENSE for more information.
 #
 
-include $(TOPDIR)/.host.mk
-
-$(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host-build.mk
-       echo "HOST_OS:=`uname`" > $@
-       echo "HOST_ARCH:=` \
-               $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
-                       -e 's/sparc.*/sparc/' \
-                       -e 's/arm.*/arm/' \
-                       -e 's/m68k.*/m68k/' \
-                       -e 's/ppc/powerpc/' \
-                       -e 's/v850.*/v850/' \
-                       -e 's/sh[234]/sh/' \
-                       -e 's/mips-.*/mips/' \
-                       -e 's/mipsel-.*/mipsel/' \
-                       -e 's/cris.*/cris/' \
-                       -e 's/i[3-9]86/i386/'`" >> $@
-       echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
-
+include $(INCLUDE_DIR)/host.mk
 
 ifneq ($(strip $(PKG_CAT)),)
   ifeq ($(PKG_CAT),unzip)