add PKG_HOST_ONLY variable to prevent target builds
[openwrt-10.03/.git] / include / host-build.mk
index 892cde91f5b040b5f1a976b0ec0e4a11665fffd5..a6118fb06f576d0183f5907b4d8f9f69f6be7fc1 100644 (file)
@@ -97,7 +97,7 @@ endef
 ifndef DUMP
   define HostBuild
   $(if $(QUILT),$(Host/Quilt))
-  $(if $(STAMP_PREPARED),,$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
+  $(if $(if $(PKG_HOST_ONLY),,$(STAMP_PREPARED)),,$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
   $(if $(DUMP),,$(call HostHost/Autoclean))
 
   $(HOST_STAMP_PREPARED):