allow packages to forcibly disable the svn/git mirror downloading attempt by setting...
[openwrt-10.03/.git] / include / download.mk
index 74986be598e84e31d331771811e7c10a8d0373cd..f064ee9e8cf32faa52e4e0566d648a0627b03814 100644 (file)
@@ -41,7 +41,7 @@ define DownloadMethod/default
 endef
 
 define wrap_mirror
-       @$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x" || ( $(1) )
+       $(if $(MIRROR),@$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x" || ( $(1) ),$(1))
 endef
 
 define DownloadMethod/cvs
@@ -101,6 +101,7 @@ define Download/Defaults
   PROTO:=
   MD5SUM:=
   SUBDIR:=
+  MIRROR:=1
   VERSION:=
 endef