[backfire] backport r27648
[openwrt-10.03/.git] / include / depends.mk
index b74e535506a382f128b996342f730cc6f09048ff..65e9b25d5e564499d4bf26d6ba871fbcffca39f5 100644 (file)
@@ -6,23 +6,42 @@
 #
 # define a dependency on a subtree
 # parameters:
-#      1: directory
+#      1: directories/files
 #      2: directory dependency
 #      3: tempfile for file listings
 #      4: find options
 
-FINDPARAMS := -type f -not -name ".*" -and -not -path "*.svn*" 
+DEP_FINDPARAMS := -x "*/.svn*" -x ".*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check"
+
+find_md5=find $(1) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) | md5s
+
 define rdep
-  $(foreach file,$(shell find $(1) $(FINDPARAMS) -and -not -path "*:*" $(4)),
-    $(2): $(file)
-    $(file): ;
-  )
+  .PRECIOUS: $(2)
+  .SILENT: $(2)_check
 
-  ifneq ($(shell find $(1) $(FINDPARAMS) $(4) 2>/dev/null | md5s),$(shell cat $(3) 2>/dev/null))
-    $(2): $(3)
-  endif
-  
-  $(3): FORCE
-       @find $(1) $(FINDPARAMS) $(4) 2>/dev/null | md5s > $$@
+  $(2): $(2)_check
+  $(2)_check::
+       if [ -f "$(2)" ]; then \
+               $(if $(3), \
+                       $(call find_md5,$(1),$(4)) > $(3).1; \
+                       { [ \! -f "$(3)" ] || diff $(3) $(3).1 >/dev/null; } && \
+               ) \
+               { \
+                       [ -f "$(2)_check.1" ] && mv "$(2)_check.1"; \
+                   $(TOPDIR)/scripts/timestamp.pl $(DEP_FINDPARAMS) $(4) -n $(2) $(1) && { \
+                               $(call debug_eval,$(SUBDIR),r,echo "No need to rebuild $(2)";) \
+                               touch -r "$(2)" "$(2)_check"; \
+                       } \
+               } || { \
+                       $(call debug_eval,$(SUBDIR),r,echo "Need to rebuild $(2)";) \
+                       touch "$(2)_check"; \
+               }; \
+               $(if $(3), mv $(3).1 $(3);) \
+       else \
+               $(if $(3), rm -f $(3) $(3).1;) \
+               $(call debug_eval,$(SUBDIR),r,echo "Target $(2) not built";) \
+               true; \
+       fi
 
 endef
+