[backfire] backport r27648
[openwrt-10.03/.git] / include / depends.mk
index b488af9271893739abd9a24d153ec6c3afc855d0..65e9b25d5e564499d4bf26d6ba871fbcffca39f5 100644 (file)
@@ -11,7 +11,7 @@
 #      3: tempfile for file listings
 #      4: find options
 
-DEP_FINDPARAMS := -x "*.svn*" -x ".*" -x "*.svn*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check"
+DEP_FINDPARAMS := -x "*/.svn*" -x ".*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check"
 
 find_md5=find $(1) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) | md5s
 
@@ -28,7 +28,7 @@ define rdep
                ) \
                { \
                        [ -f "$(2)_check.1" ] && mv "$(2)_check.1"; \
-                   $(SCRIPT_DIR)/timestamp.pl $(DEP_FINDPARAMS) $(4) -n $(2) $(1) && { \
+                   $(TOPDIR)/scripts/timestamp.pl $(DEP_FINDPARAMS) $(4) -n $(2) $(1) && { \
                                $(call debug_eval,$(SUBDIR),r,echo "No need to rebuild $(2)";) \
                                touch -r "$(2)" "$(2)_check"; \
                        } \