[backfire] merge r26589
[openwrt-10.03/.git] / include / autotools.mk
index 24f9b721ddf1ad401d8135cb8e5e7c395b320cf3..7fe376cc156b7e5401192288ab1be614e009f078 100644 (file)
@@ -38,9 +38,12 @@ define autoreconf
                                [ -d $(p)/autom4te.cache ] && rm -rf autom4te.cache; \
                                touch NEWS AUTHORS COPYING ChangeLog; \
                                $(AM_TOOL_PATHS) $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+                                       $(if $(word 2,$(3)),--no-recursive) \
                                        -B $(STAGING_DIR_HOST)/share/aclocal \
                                        $(patsubst %,-I %,$(5)) \
                                        $(patsubst %,-I %,$(4)) $(4) || true; \
+                               [ -e $(p)/config.rpath ] || \
+                                               ln -s $(SCRIPT_DIR)/config.rpath $(p)/config.rpath;
                        fi; \
                ) \
        );