fix a small dep bug in the docs/ dir
[openwrt-10.03/.git] / docs / Makefile
index cdaf09c1e04ffdb09afb9d38d6f477c1ab1e3377..8bae4625af991c77ad6b1ab6303a6383b493526f 100644 (file)
@@ -1,6 +1,7 @@
 ifeq ($(TOPDIR),)
   TOPDIR:=${CURDIR}/..
 endif
+PKG_NAME=docs
 
 all: compile
 
@@ -10,7 +11,7 @@ include $(INCLUDE_DIR)/prereq.mk
 MAIN = openwrt.tex
 DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex $(TMP_DIR)/.prereq-docs
 
-compile:
+compile: $(TMP_DIR)/.prereq-docs
        $(NO_TRACE_MAKE) cleanup
        latex $(MAIN)
        $(NO_TRACE_MAKE) openwrt.pdf openwrt.html