add html output for the documentation (using tex4ht)
[openwrt-10.03/.git] / docs / Makefile
index 8c3ca646ddf757b967c0ba7f7111f89fc31616bb..359f4e63080dcfaf10a3fae2a5bb3c1a8eeb38dc 100644 (file)
@@ -1,14 +1,23 @@
-openwrt.pdf: Makefile openwrt.tex config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex
+MAIN = openwrt.tex
+DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex
+
+all:
        $(MAKE) cleanup
-       pdflatex openwrt.tex
-       pdflatex openwrt.tex
+       latex $(MAIN)
+       $(MAKE) openwrt.pdf openwrt.html
        $(MAKE) cleanup
+
+openwrt.html: $(DEPS)
+       htlatex $(MAIN)
+
+openwrt.pdf: $(DEPS)
+       pdflatex $(MAIN)
        
 clean: cleanup
-       rm -f openwrt.pdf
+       rm -f openwrt.pdf openwrt.html openwrt.css
 
 cleanup: FORCE
-       rm -f *.log *.aux *.toc *.out
+       rm -f *.log *.aux *.toc *.out *.lg *.dvi *.idv *.4ct *.4tc *.xref *.tmp *.dvi
 
 
 FORCE: