next round of build system cleanup - convert package/ to new structure
[openwrt-10.03/.git] / Makefile
index b1bcf91a132f8268a5b469521b021bc439c3ccf1..fbed1297a1eb6c8fd915a0afc3579504af563bc6 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,90 +1,69 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
+# Copyright (C) 2007 OpenWrt.org
 #
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-#
-
-RELEASE:=Kamikaze
-#VERSION:=2.0 # uncomment for final release
-
-#--------------------------------------------------------------
-# Just run 'make menuconfig', configure stuff, then run 'make'.
-# You shouldn't need to mess with anything beyond this point...
-#--------------------------------------------------------------
-TOPDIR=${shell pwd}
-export TOPDIR
-
-OPENWRTVERSION:=$(RELEASE)
-ifneq ($(VERSION),)
-OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
-else
-REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
-ifneq ($(REV),)
-OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
-endif
-endif
-export OPENWRTVERSION
 
-all: world
+TOPDIR:=${CURDIR}
+LC_ALL:=C
+LANG:=C
+IS_TTY:=${shell tty -s && echo 1 || echo 0}
+export TOPDIR LC_ALL LANG IS_TTY
 
-.pkginfo: FORCE
-ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
-       @echo Collecting package info...
-       @-for dir in package/*/; do \
-               echo Source-Makefile: $${dir}Makefile; \
-               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
-       done > $@
-endif
-
-.config.in: .pkginfo
-       ./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
-
-pkginfo-clean: FORCE
-       -rm -f .pkginfo .config.in
-
-scripts/config/mconf: .config.in
-       $(MAKE) -C scripts/config all
+world:
 
-scripts/config/conf: .config.in
-       $(MAKE) -C scripts/config conf
+include $(TOPDIR)/include/debug.mk
+include $(TOPDIR)/include/host.mk
 
-menuconfig: scripts/config/mconf
-       $< Config.in
+ifneq ($(OPENWRT_BUILD),1)
+  override OPENWRT_BUILD=1
+  export OPENWRT_BUILD
+  include $(TOPDIR)/include/toplevel.mk
+else
+  include rules.mk
+  include $(INCLUDE_DIR)/depends.mk
+  include $(INCLUDE_DIR)/subdir.mk
+  include package/Makefile
+  include tools/Makefile
+  include toolchain/Makefile
 
-config: scripts/config/conf
-       $< Config.in
+clean: FORCE
+       rm -rf build_* bin tmp
 
-config-clean:
-       $(MAKE) -C scripts/config clean
+dirclean: clean
+       rm -rf staging_dir_* toolchain_build_* tool_build
 
-package/%: .pkginfo
-       $(MAKE) -C package $(patsubst package/%,%,$@)
+distclean: dirclean config-clean symlinkclean docs/clean
+       rm -rf dl
 
-target/%: .pkginfo
-       $(MAKE) -C target $(patsubst target/%,%,$@)
+target/%: FORCE
+       $(MAKE) -C $(patsubst %/$*,%,$@) $*
 
-toolchain/%:
-       $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
+# check prerequisites before starting to build
+prereq: tmp/.prereq-target $(package/stamp-prereq) ;
 
-world:
-       $(MAKE) toolchain/install
+world: .config $(tools/stamp-install) $(toolchain/stamp-install) FORCE
        $(MAKE) target/compile
        $(MAKE) package/compile
        $(MAKE) package/install
        $(MAKE) target/install
+       $(MAKE) package/index
+
+package/symlinks:
+       $(SCRIPT_DIR)/feeds.sh $(CONFIG_SOURCE_FEEDS) $(CONFIG_SOURCE_FEEDS_REV)        
+
+# FIXME: remove after converting target/ to new structure
+tmp/.prereq-target: tmp/.targetinfo .config
+tmp/.prereq-target: include/prereq.mk 
+       mkdir -p tmp
+       rm -f tmp/.host.mk
+       @+$(NO_TRACE_MAKE) -s -C target prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       touch $@
+.SILENT: tmp/.prereq-target
 
-.PHONY: FORCE
-FORCE:
+endif