next round of build system cleanup - convert package/ to new structure
[openwrt-10.03/.git] / Makefile
index 06288de6b86b1d1ab061080b8f4d5e6177d8e3e6..fbed1297a1eb6c8fd915a0afc3579504af563bc6 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,74 +1,69 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
+# Copyright (C) 2007 OpenWrt.org
 #
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
 
-RELEASE:=Kamikaze
-#VERSION:=2.0 # uncomment for final release
+TOPDIR:=${CURDIR}
+LC_ALL:=C
+LANG:=C
+IS_TTY:=${shell tty -s && echo 1 || echo 0}
+export TOPDIR LC_ALL LANG IS_TTY
 
-#--------------------------------------------------------------
-# Just run 'make menuconfig', configure stuff, then run 'make'.
-# You shouldn't need to mess with anything beyond this point...
-#--------------------------------------------------------------
-TOPDIR=${shell pwd}
-export TOPDIR
+world:
 
-OPENWRTVERSION:=$(RELEASE)
-ifneq ($(VERSION),)
-OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
-else
-REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
-ifneq ($(REV),)
-OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
-endif
-endif
-export OPENWRTVERSION
+include $(TOPDIR)/include/debug.mk
+include $(TOPDIR)/include/host.mk
 
-all:
+ifneq ($(OPENWRT_BUILD),1)
+  override OPENWRT_BUILD=1
+  export OPENWRT_BUILD
+  include $(TOPDIR)/include/toplevel.mk
+else
+  include rules.mk
+  include $(INCLUDE_DIR)/depends.mk
+  include $(INCLUDE_DIR)/subdir.mk
+  include package/Makefile
+  include tools/Makefile
+  include toolchain/Makefile
 
-.pkginfo: FORCE
-ifeq ($(shell ./scripts/timestamp.pl -p .pkginfo package),package)
-       @echo Collecting package info...
-       @-for makefile in package/*/Makefile; do \
-               echo Source-Makefile: $$makefile; \
-               $(MAKE) DUMP=1 -f $$makefile 2>&- || true; \
-       done > $@
-endif
+clean: FORCE
+       rm -rf build_* bin tmp
 
-.config.in: .pkginfo
-       ./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
+dirclean: clean
+       rm -rf staging_dir_* toolchain_build_* tool_build
 
-pkginfo-clean: FORCE
-       -rm -f .pkginfo .config.in
+distclean: dirclean config-clean symlinkclean docs/clean
+       rm -rf dl
 
-scripts/config/mconf: .config.in
-       $(MAKE) -C scripts/config all
+target/%: FORCE
+       $(MAKE) -C $(patsubst %/$*,%,$@) $*
 
-scripts/config/conf: .config.in
-       $(MAKE) -C scripts/config conf
+# check prerequisites before starting to build
+prereq: tmp/.prereq-target $(package/stamp-prereq) ;
 
-menuconfig: scripts/config/mconf
-       $< Config.in
+world: .config $(tools/stamp-install) $(toolchain/stamp-install) FORCE
+       $(MAKE) target/compile
+       $(MAKE) package/compile
+       $(MAKE) package/install
+       $(MAKE) target/install
+       $(MAKE) package/index
 
-config: scripts/config/conf
-       $< Config.in
+package/symlinks:
+       $(SCRIPT_DIR)/feeds.sh $(CONFIG_SOURCE_FEEDS) $(CONFIG_SOURCE_FEEDS_REV)        
 
-config-clean:
-       $(MAKE) -C scripts/config clean
+# FIXME: remove after converting target/ to new structure
+tmp/.prereq-target: tmp/.targetinfo .config
+tmp/.prereq-target: include/prereq.mk 
+       mkdir -p tmp
+       rm -f tmp/.host.mk
+       @+$(NO_TRACE_MAKE) -s -C target prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       touch $@
+.SILENT: tmp/.prereq-target
 
-.PHONY: FORCE
-FORCE:
+endif